Resolvendo Problema com dispositivo /dev/dsp ao programar em JME

Nas versões mais novas do Ubuntu o dispositivo /dev/dsp simplesmente não existe, pois ele pertence ao pacote OSS, e o modulo não vem instalado, muitas aplicações utilizam o OSS, por este motivo o pacote Pulse Audio vem com um “emulador” chamado padsp, que emula as chamadas ao /dev/dsp,redirecionando ao proprio PulseAudio, como o Pulse Audio vem instalado no Ubuntu, para utiliza-lo, use o comando:

padsp nome_da_aplicacao

Para fazer com que suas aplicações JME rodem com áudio execute o NETBEANS desta forma

padsp netbeans

Se você utiliza o gnome, adicione o comando em um lançador:

Até a próxima;

Abraço..

Se gostou deixa um comentário….

Contornando o problema compilação do Emulador PCSX2 no Ubuntu 12.04

Tem um erro chato ao compilar o PCSX2 que é o seguinte:

/home/PROGRAMAS/instalados/source/pcsx2/pcsx2-read-only/plugins/GSdx/GS.cpp: No escopo global:
/home/PROGRAMAS/instalados/source/pcsx2/pcsx2-read-only/plugins/GSdx/GS.cpp:65:13: aviso: ‘s_isgsopen2’ defined but not used [-Wunused-variable]
make[2]: ** [plugins/GSdx/CMakeFiles/GSdx-0.1.16.dir/GS.cpp.o] Erro 1
make[1]: ** [plugins/GSdx/CMakeFiles/GSdx-0.1.16.dir/all] Erro 2
make: ** [all] Erro 2

Este erro ocorre por algum problema no plugin GSDX, então apenas indique ao make que ele não deve tentar compilar esse plugin, para isso:

1- Edite o arquivo CMakeLists.txt no diretório plugins

gedit /home/PROGRAMAS/instalados/source/pcsx2/pcsx2-read-only/plugins/CMakeLists.txt

2- Comente as seguintes linhas, conforme abaixo:

# make GSdx
#if(EXISTS “${PROJECT_SOURCE_DIR}/plugins/GSdx” AND GSdx)
#    add_subdirectory(GSdx)
# endif(EXISTS “${PROJECT_SOURCE_DIR}/plugins/GSdx” AND GSdx)

3- Repita o processo de compilação do PCSX2.

4- Alguém vai me dizer “ahhhh Moacir, mas e agora, como eu fico sem o plugin gráfico?”.
R. Bem.Procure na versão instalável via apt-get
https://launchpad.net/~gregory-hainaut/+archive/pcsx2.official.ppa
Após terminar a compilação, substitua os plugins do diretório de plugins compilados do PCSX2 pelos plugins da versão instalada via apt-get.

Eu pessoalmente uso uma mescla de plugins compilados e outros da versão via apt-get, mas não uso pcsx2 da versão apt-get, pois compilar na própria maquina me traz mais ganho em performance,pode ser um tanto controverso isso, mas eu notei melhoras.

Obs.: Tenho noção que essa dica foi muito rápida, se alguém se interessar ou ficar com dúvidas posta um comentário pedindo um artigo mais elaborado sobre a compilação que eu farei sem problema algum.

ESSA “CASA” NÃO FORNECE BIOS, POR FAVOR NÃO INSISTA!

E desculpe por repetir tanto a palavra plugin, chegou a ser irritante….rsrsrs
Abraço

Instalando o JDK da Sun/Oracle no Ubuntu 10.4

Vamos instalar e configurar o JDK  no Ubuntu e depois substituir a o OPEN JDK pela versão da Oracle, que é mais compativel com a maioria dos sites que existem por aí, e sem nem sentir o cheiro do console, apenas usando as ferramentas gráficas disponiveis no Ubuntu, elas estão aí pra isso.

“Boa sorte…”

Siga os passos

Va até Aplicativos –>Central de Programas do Ubuntu –> instale os seguintes pacotes: Configurador Alternatives, default-jdk
Escolhi instalar o JDK ao inves da JRE, pois assim estou sendo útil a programadores e usuários não nerds desenvolvedores.

Execute o programa Configurador Alternatives em Aplicativos–>Ferramentas de Sistema.

Este programa serve para você configurar as alternativas para inúmeros softwares, então na maioria das vezes, as  alternativas livres e programas devidamente alterados para funcionarem no Ubuntu, são mantidos como PADRÃO, para o JDK da Oracle, temos o OpenJDK , para o Mozilla Firefox temos Mozila Firefox for Ubuntu, o problema é que as vezes esses softwares não são totalmente compatíveis com nossas necessidades.

Agora altere todas as alternativas que tem relação com java da seguinte forma, por exemplo a appletviewer:

1- Selecione appletviewer no esquerda,note que a no meu caso a alternativa padrão é o OpenJdk, então clique no botão Adicionar.

2- Ao clicar em Adicionar, clique no botão Navegar..

3- Agora você deve selecionar o Java da Oracle conforme a imagem:

4- Agora marque a nova alternativa como padrão, como a figura abaixo:

5- Se você desejar, realize o mesmo procedimento para todas as outra opções(extcheck, idlj,jar, jarsigner, javajavac, javadoc, javah, javap, javaws, jconsole, jdb, jhat, jinfo, jmap, jps, jrunscript), as que eu deixe em negrito são as que eu acho que você deveria realizar o procedimento.

6- Agora o ultimo e mais importante passo, vamos configurar o plugin java para o mozilla-firefox (Oba! Sem problemas com o Banco do Brasil), configure conforme a imagem abaixo:

Até a próxima…

Abrass

Instalando o Wink 1.5 no Ubuntu 10.4

Pra quem não sabe, Wink é um software para criação de tutoriais e apresentações, abaixo segue o link do site programa

http://www.debugmode.com/wink/

O problema principal na instalação deste programa, esta no fato de ele usar a biblioteca libstdc++5 e o Ubuntu 10.4 possuir a versão libstdc++6. Antigamente para instala-lo era só usar o menu Central de Programas que tudo era feito “automagicamente”, atualmente ele nem é listado no menu citado anteriormente, eu realmente acho que este tipo de erro é o que mais colabora para o Linux ser o que é hoje em dia, ou seja uma “bagunça organizada”.

Sem papo furado, mãos a obra…

1-Baixe o wink que iremos instalar aqui

http://yet.another.linux-nerd.com/wink/download/wink15.tar.gz

2-Baixe a versão 5 do libstdc++ aqui

http://ftp.us.debian.org/debian/pool/main/g/gcc-3.3/libstdc++5_3.3.6-20_i386.deb

Baixado tudo que precisamos, vamos instalar e configurar.

3- Instale a o pacote  libstdc++5_3.3.6-20_i386.deb, só dar dois cliques em cima do pacote,  e mandar instalar(após a instalação a janela do instalador travou, eu simplesmente fechei forçado a janela, mas talvez isso não aconteça no seu computador).

4-Abra um console, para ver se a lib foi instalada, use o comando abaixo:

 ls /usr/lib/libstdc++.so.5

provavelmente vocẽ verá algo assim apos a execução do programa.

/usr/lib/libstdc++.so.5

5- Vamos descompactar o wink que baixamos anteriormente, botão direito do mouse em cima do arquivo wink15.tar.gz, clique em  extrair aqui.

Sera criada uma pasta chamada wink15, e dentro desta descompacte o arquivo installdata.tar.gz, o que importa para nós é o que esta dentro da pasta installdata.

6- Volte para o console, vamos precisar instalar uma biblioteca chamada libexpat.so.0, para isso, execute os comandos

sudo apt-get update

sudo apt-get install libexpat1-dev

7-Agora encontramos outro problema, se tentarmos rodar o executável do wink que esta dentro de installdata, obteremos um erro informando que libexpat.so.0 não existe, isso acontece porque no Ubuntu 10.4 esse biblioteca se chama libexpat.so, então criaremos um link simbólico chamado libexpat.so.0, que aponte para libexpat.so.Vamos criar o link então:

sudo ln -s /usr/lib/libexpat.so /usr/lib/libexpat.so.0

8-Por fim chegamos ao ultimo passo da instalação que é a criação da variável de ambiente do WINK, chamada <strong>WINK_INSTALL_DIR</strong>, execute o comando:

sudo gedit /etc/bash.bashrc

Lembre-se, antes de editar um arquivo de configuração, é importante que você faça uma copia de segurança do mesmo.

Adicione no final do arquivo o seguinte:



WINK_INSTALL_DIR=/opt/packages/instalados/wink15/installdata

PATH=$WINK_INSTALL_DIR:$PATH

export  WINK_INSTALL_DIR PATH


Salve o arquivo e saia do console, abra novamente o console, e execute  o comando como usuário normal:

wink

Até a próxima, um abraço!

Se você gostou deixa um comentário, se não gostou, deixe um comentario também.

Resolvendo problema na instalação do Flash no Debian

Para você que esta vendo essa mensagem :

E: O pacote adobe-flashplugin precisa ser reinstalado, mas não foi possível encontrar um arquivo para o mesmo.

E: Erro interno abrindo o cache (1). Por favor reporte.”

Você tentou de tudo, reinstalar, abrir o synaptic, e nada, todas as ferramentas de gerenciamento de pacotes estão travadas, para resolver, é só realizar os passos abaixo:

1. Como root:

cd /var/lib/dpkg/info

2. Remover os seguintes arquivos:

adobe-flashplugin.list

adobe-flashplugin.prerm

adobe-flashplugin.postinst

3. Reinstalar o pacote:

Esse problema é causado por uma instalação incompleta de algum pacote, ou seja, as ferramentas de gerenciamento de pacotes ficam “travadas” até que instalação seja completada, mas como completar a instalação se ela esta bloqueada? É necessario apagar os arquivos que estavam controlando a instalação daquele pacote.

Thats all Folks!!

Esse post pertencia ao meu antigo blog, nos comentarios,pude perceber que para algumas pessoas a solução acima funcionou para outras não, algumas pessoas comparatilharam suas soluções, então segue abaixo esta sugestões:

Marcos

ensaius.wordpress.com

Consegui deletar o programa com esse comando:

sudo dpkg –remove –force-remove-reinstreq adobe-flashplugin

Lourilúcio

lourilucio@gmail.com

Amigo, no meu caso só isso não foi suficiente… depois de muito ralar encontrei essa ajuda que salvou minha instalação:

$ sudo rm /var/lib/dpkg/info/adobe-flashplugin.prerm

$ sudo dpkg-reconfigure adobe-flashplugin –force

$ sudo dpkg –purge –force-all adobe-flashplugin

$ sudo apt-get install flashplugin-nonfree

instalar pelo repositório o ubuntu-restrict-extra